Data Translation Basics

Interoperability .......................................................................................................................... 3
  What is Interoperability? ................................................................................................................. 3
Barriers to Interoperability ............................................................................................................. 4
  Data Types ..................................................................................................................................... 4
  Data Formats.................................................................................................................................. 5
Interoperability Solutions .................................................................................................................. 6
  Data Standards ............................................................................................................................... 6
  Data Translation ............................................................................................................................ 7
  Data Transformation ....................................................................................................................... 8
Introduction to FME .......................................................................................................................... 9
  What is FME? .................................................................................................................................. 9
  How Does FME Work? ..................................................................................................................... 9
FME Editions and Licensing ............................................................................................................. 10
  FME Desktop Editions .................................................................................................................... 10
  FME Licensing ............................................................................................................................... 10
FME Desktop Components ............................................................................................................... 11
  FME Applications .......................................................................................................................... 11
  Other FME Components ................................................................................................................ 11
Other FME Products .......................................................................................................................... 12
  FME Server ................................................................................................................................... 12
  FME Extensions ............................................................................................................................. 12
Introduction to FME Workbench ...................................................................................................... 13
  What is FME Workbench? ............................................................................................................... 13
  Major Components of FME Workbench .......................................................................................... 14
  Window Control ............................................................................................................................. 15
Setting up a Translation ..................................................................................................................... 18
  Dialog or Wizard ............................................................................................................................ 18
  The New Workspace ....................................................................................................................... 20
Introduction to Data Inspection ........................................................................................................ 22
  What is Data Inspection? ................................................................................................................ 22
Introduction to FME Universal Viewer ........................................................................................... 22
  What is FME Universal Viewer? .................................................................................................... 23
  Major Components of the FME Universal Viewer ....................................................................... 24
Using FME Universal Viewer ......................................................................................................... 25
  Viewing Data .................................................................................................................................. 25
  Inspecting Data ............................................................................................................................... 26
More FME Universal Viewer Functionality ..................................................................................... 28
  Display Control ............................................................................................................................... 28
  Miscellaneous Viewer Functionality ............................................................................................... 29
Raster Data and FME Universal Viewer ........................................................................................... 32
  Opening a Raster Data in the Viewer .............................................................................................. 32
  Querying Raster Features ................................................................................................................. 33
Translation Previews ....................................................................................................................... 36
  Redirect to Inspection Application .................................................................................................. 36
Introduction to FME Quick Translator ............................................................................................. 36
  What is the FME Quick Translator? ............................................................................................... 37
  Setting up a Translation .................................................................................................................. 37
Module Review ............................................................................................................................... 40
  What You Should Have Learned from this Module ........................................................................ 40
Appendix A: Supported Geometries ............................................................................................... 42
Interoperability

*FME's marketing materials state that “FME is the dominant technology for solving spatial data interoperability headaches”.*

What is Interoperability?

Interoperability is about communication; in our case communication by the sharing and distribution of data, and the ability to use that data transparently. The key words in this definition are:

- **Communication**: The exchange of information
- **Data Sharing/Distribution**: Supplying either the data itself, or direct access to the source
- **Transparently**: Without the need for background knowledge of the data structure

Interoperability is sometimes also known as Data Harmonization or Data Model Transformation.

Example of Interoperability

Police Chief Webb-Mapp says...

“When emergency services work in isolation - whether it is spatial data, rescue equipment or radio frequencies - then chaos can ensue. Interoperability is important for coordinating emergency response efforts.”
Barriers to Interoperability

Unfortunately, interoperability is not always easy. For spatial data there are two major barriers.

Data Types
In the spatial data world there are many 'types' of data; for example CAD, GIS, BIM (Building Information), Navigational, and so forth.

Because the different types of data are designed for different purposes they are not always compatible with one another. We can say they have different meanings.

For example, a navigational system such as an in-car GPS and a CAD dataset for a civil engineering project may both deal with the concept of "roads", but their views of the data will be quite different.

The navigational data will include a generalized – but topological - network of data with traffic based attributes. The CAD data will include precise positional geometry and attributes concerning road surface. Neither data is easily interoperable with the other.
Data Formats
Also unique to the world of spatial data is the number of ‘formats’ of data; for example, Geodatabase, DWG, MIF/MID, KML, and so forth.

Because different datasets have different formats, they are not always compatible with the same computer applications, even if they are of the same type.

For example, a system that reads Geodatabase datasets may not also be capable of importing MapInfo TAB data, despite the fact that both of these are GIS type datasets. A GPS unit might be able to read GPX data, but not NMEA.
Interoperability Solutions

To overcome the barriers to spatial data interoperability, there are a number of solutions.

Data Standards
The most obvious solution to a lack of interoperability is Data Standards. If everyone used the same type and format of data then there would be no problems sharing it.

Standards can be divided into Formats or Data Models, and some standards are both! Some are used to store data, and some used merely as a vehicle for exchanging datasets.

Common Standards
Many key spatial standards are created and/or maintained by the OGC (Open Geospatial Consortium), a non-profit and international standards organization.

ISO (International Organization for Standardization) also produces some standards, such as S-57.

Other standards are created either ad-hoc or for a particular country only. These may be entirely new or may be an extension or a subset of an OGC or ISO standard.

Some common standards:

**OGC:** GML, KML, WKT, WKB

**National:** MasterMap (UK – a data model based on OGC GML)
TIGER/Line (US – both a format and a data model)
KF85 (Sweden) and NAS (Germany)

**Others:** S-57 (both a format and a data model)
GeoJSON, GeoRSS, LandXML, CIM (Common Information Model)
VPF (format) and VPF products (DNC, VMAP, World Vector Shoreline)

Pros and Cons
On the whole standards work well for simple datasets, but when faced with greater complexity either become complex themselves, or become hived off into new standards.

In the previous example – where a CAD and Navigational dataset had a different view of “roads” – it’s hard to see a single standard that could reconcile both of these points of view.

Also, governments are not always known for close cooperation, which leads to a large number of national standards. Additionally a number of standards start out as non-spatial but later acquire spatial capabilities (GeoJSON and GeoRSS for example).

With all this – and software producers who are understandably reluctant to drop their own proprietary data formats – the number of recognized formats is probably increasing, not decreasing. This can lead to data interoperability being limited to a smaller sphere, such as an industry or particular data type.
Data Translation
A second interoperability solution is a software tool designed for Data Translation; the translation of data between different formats.

For example, applications exist to specifically convert one format of data to another, and producers of GIS/CAD systems incorporate import and export tools into their products.

However, such tools are limited in their effect because they do not solve the data type barrier. They only solve the data format barrier; and even then there can be major limitations.

The problem is that most tools of this type force data through a limited data model; i.e. the model has a limited understanding of the meaning of the data.

So such a tool might be able to convert the format of spatial data, but often loses the intent.

At Safe we typically illustrate this scenario as a pipeline. Within this limited pipeline, attributes (B and C) are lost from the newly-created dataset in Format 2.

Maybe it’s because the attributes are a special type (e.g. a domain or subtype) that the data model does not recognize or support, and so discarded (leaked) them.

Alternatively, maybe it’s because Format 2 is a different data type (e.g. for a CAD package instead of a GIS application) that does not support such attributes, and the translation tool has again discarded them, not knowing how best to represent that change of intent.

Also notice the flow arrows that show this is a one-way translation. This is a common problem for simple translation tools. And even if a return translation does exist, there’s no guarantee the data will make it back to Format 1 with the exact same content as when it left.

Ms. Surveyor says…
“Working at a land survey company I have to provide data to customers in many formats. Without FME each format requires a custom Data Translation tool to be written. Project overheads are high and limited data models cause output to vary from what the original land survey intended.”
Data Transformation
Much better than simple format conversion, is the ability to carry out Data Transformation.

Data Transformation is the ability to restructure data during format translation. Such restructuring allows a user to manually handle the differences between data types, so that no data is lost during translation.

It is also known as Transformational Translation.

Data Transformation also implies a rich geometry model, so that, for the most part, a user won’t have to use manual techniques. The application will automatically handle the data type differences, as well as the format differences, to keep all data and its meaning during automated translations.

FME is a tool specifically designed for Data Transformation. It has a rich data model and the ability for users to manually define data restructuring in order to best fit the destination format.

Ms. Surveyor says...

“Now that I use FME I can translate spatial data between different formats AND transform the data to the required structure, without any custom coding. Project overheads have plummeted, and the resulting data is high quality and reflects the original land survey.”
Introduction to FME

FME is specifically designed for Data Transformation. Its key characteristics illustrate why it is so suitable for this role.

What is FME?
As noted, FME (Feature Manipulation Engine) was designed as a Data Transformation tool. In fact, because it can read, write and transform spatial data, it is often classed as a Spatial ETL application.

ETL stands for Extract, Transform and Load. It is a data warehousing tool that extracts data from a source, transforms it to fit the users’ needs and loads it into a destination or data warehouse.

A Spatial ETL tool is the geographic equivalent of ETL.

While an ETL tool will process the various column types that are in a non-spatial database or system, a Spatial ETL tool must also have the spatial operations - geoprocessing capabilities that change the structure and representation of spatial data – needed to move data from one spatial database or GIS to another.

How Does FME Work?
FME has a number of key characteristics:

Centralized
FME is a central engine among an array of supported format. Data can be read from any format and written to any other.

Adding support for a new format is as simple as plugging it into the FME engine.

FME can support both raster and vector formats under the same centralized model.

Semantic
FME has a rich data model designed to cover all possible geometry and attribute types. When limitations in the destination (output) format cause incompatibility, FME automatically compensates to create a seamless translation process.

Transformational
The ‘T’ in ETL is what Format Translation tools lack. FME provides tremendous transformation functionality, resulting in output that can be much greater than the sum of the inputs, and allowing data to be transformed from one type (for example, GIS) to another (for example, CAD).
FME Editions and Licensing

FME comes in a range of different editions that vary according to the needs of the user.

FME Desktop Editions
FME is available in a number of editions.

Each edition has a different set of functions and formats available, but includes all the features from lesser editions.

The editions are:

FME Base edition
This is an entry-level FME edition that supports 40 formats and a set of basic transformation tools.

FME Professional edition
This is a general purpose FME edition with more formats and the full set of transformation tools.

Esri/Intergraph editions
These editions add support for formats tied to a specific application; for example the Esri edition includes support for Geodatabase and the Intergraph edition support for writing GeoMedia.

Oracle/SQL Server/DB2 editions
These editions add support for mostly database formats; for example the Oracle edition includes support for writing to Oracle Spatial databases.

Smallworld
This edition adds support for GE Smallworld reading and writing.

Always check www.safe.com for the latest info on which editions support which formats.

FME Licensing
A common mistake is to think each edition is a different download/installer file. This is not true. All editions of FME Desktop have the same installer, with different functionality being unlocked by different licenses.

FME has two licensing methods:

Node-Locked (Fixed) License
A node-locked license is for use with FME on a specific computer only. The license cannot be transferred to another computer except by a special request to Safe Software.

Floating License
Floating licenses are held on a server and issued to individual users as they start up FME. This is useful for the situation where there are many FME users, but not all using FME at the same time.
FME Desktop Components

FME comprises a number of spatial data handling components. Everything here is included with every edition of FME Desktop.

FME Applications
There are three key applications within FME; FME Workbench, FME Universal Viewer, and FME Quick Translator.

FME Workbench
FME Workbench has an intuitive point-and-click graphic interface to enable translations to be graphically described as a flow of data. FME Workbench is the primary tool for data translations in FME.

FME Universal Viewer
The FME Universal Viewer utility allows quick viewing of data in any of the FME supported formats. It is used primarily for data validation and quality assurance by allowing the previewing of data before translation or its reviewing after translation.

FME Quick Translator
The FME Quick Translator is a descendent of the FME Universal Translator, which used a scripting language (Mapping Files) rather than a graphic interface. It is used for quick format translations, or for running more sophisticated translations created in FME Workbench.

Other FME Components
Additional components are also included as part of FME Desktop (Professional Edition or higher).

FME Command Line Engine
The FME Command Line Engine enables translations to be initiated at the command line level.

FME Application Extenders
FME Application Extenders are FME components embedded into other GIS applications. These commonly enable a GIS product to view datasets not native to that application.

FME Objects
FME Objects is a software library for working with spatial data. Application developers use FME Objects to add spatial data reading and writing support into their stand-alone applications.

FME Plug-In SDK
The FME Plug-In SDK allows developers to add formats and functionality to the FME core.
Other FME Products

The FME brand name covers other products than FME Desktop.

FME Server
Using the same underlying technology as FME Desktop, FME Server is a networked Data Transformation application. It can operate on a local-area network, or on the Internet.

FME Server:
- Allows Desktop users to share translation resources through a repository mechanism
- Allows Desktop users to run resource intensive translations on a dedicated server
- Allows non-FME users to run translations on demand
- Allows translation output to be streamed directly to a chosen spatial application

In other words, FME Server facilitates sharing of spatial data; where, when and how the end user needs it.

FME Server is scalable, and so can easily grow as demands on the system increase.

FME Server is also a Model-Driven Architecture (MDA) meaning it processes data using pre-defined workflows. These workflows are defined using FME Desktop, making it simple to convert a desktop process to one usable by a client anywhere.

See www.safe.com/fmeserver for more product information.

FME Extensions
Besides the basic functionality of FME Desktop, there are a number of optional extra extensions that may be purchased. These extensions add to either the functionality or format reach of the basic FME product.

Example extensions include:
- MRFCleaner transformer for geometry cleaning
- CurveFitter transformer for line smoothing
- GDF format read/write support
- VPF format write support

Again, see the Safe Software web site for more information.
Introduction to FME Workbench

Workbench is FME’s primary tool for data translations. Its intuitive point-and-click graphic interface allows translations to be graphically described as a flow of data.

What is FME Workbench?
FME Workbench is an application for defining data translation and transformation processes.

With Workbench, underlying FME functionality is exposed in an intuitive interface that allows users to graphically define a custom dataflow from source, through transformation, to destination.

Workbench has tools for defining the source and destination dataset structure (or schema), and also for manipulating the geometry and attributes of spatial data.

Workbench is fully integrated to interact with other FME applications such as the FME Universal Viewer and other products such as FME Server, and is the authoring tool for FME Server models.

Starting FME Workbench
Find FME Workbench in the FME Desktop sub-menu in the Windows start menu. Click on the sub-menu entry to start Workbench.

When FME Workbench starts, it opens with a startup screen shown as a tabbed window. This window has shortcuts to tools for defining a translation, and also shows information to help get users started with FME.

The startup tab links to a live web page and therefore the display will change over time as new information and resources are shown.

A second tab – Main – displays a canvas where the actual translation will be graphically defined.
Major Components of FME Workbench
The FME Workbench user interface has a number of major components.

Menu bar and Toolbar
The menu bar and toolbar contain a number of tools: for example, tools for navigating around the workspace, controlling administrative tasks, and adding or removing Reader (source) datasets.

Canvas
The FME Workbench canvas is where users graphically define a translation. This definition is called a “workspace” and can be saved for re-use later.

By default the workspace reads from left to right; data source on the left, transformation tools in the center, and data destination on the right. Connections between each item represent the flow of data and may branch in different directions or even lead to a dead-end if required.

To be precise the application itself is called Workbench, but the process defined in the canvas window is called a “Workspace”. The terms are so similar that they are easily confused. The difference is minor so it doesn’t really matter, but listen to certain instructors grind their teeth when you get it wrong!

Navigator
The navigator is an explorer type tool that shows a text definition of source and destination datasets, plus all settings that apply to these datasets.

Transformer Gallery
The transformer gallery is a tool for the location and selection of FME transformation tools.

Translation Log
The log window (translation log) shows a report on translation results. Information includes any warning or error messages, translation status, length of translation, and number of features processed.

Overview Window (Not shown above)
The overview window shows a small-scale view of the current FME workspace, and is therefore most useful when a large workspace is being worked upon.
Window Control

All windows in the Workbench interface can be detached from a fixed position and deposited in a custom location by clicking on the frame of the window and dragging it into a new position. The windows can even float outside of the main Workbench window.

Windows can be docked within Workbench by dragging them onto the Workbench window frame. Windows can be docked to either the left, right, upper or lower boundaries of the Workbench frame.

This user has opted to dock the Navigator and Transformer Gallery on the left and right sides of Workbench respectively. The Log window is docked in its traditional position at the bottom of the window.

InteropGeek68 says...

“I use multiple monitors. Then I can float Workbench menus onto a different monitor, and leave the main monitor free for the workspace canvas.”

In FME2012, the F11 button toggles the Workbench canvas between full screen mode and back again. Shift+F11 does the same thing, but leaves the menubar and toolbar available for use. The F11 option is also available as a toolbar button:
When two or more windows are docked in the same location there is the option to arrange them either stacked or tabbed.

Stacking windows (such as the Navigator and Transformer Gallery) means one appears above the other.

The option to stack or tab windows (or to permit them to float separately) is controlled by the down-arrow button located at the top of each window frame.

At the bottom of the Log window, there are two tabs. Click a transformer on the Transformer Gallery or on the canvas, and then click the Transformer Description tab for details about that transformer. Click the Log tab to show the log summary in the Log window.

Each user may have a preferred layout so feel free to adjust the windows in whichever way works best for you.
Miss Vector says…

‘Attention please! It’s time for a quiz to see what you’ve learned so far. Turn to a fellow student and answer these questions between you.’

Which of the following words describe FME Desktop?

1) Distributed
2) Semantic
3) Transformational
4) Centralized

Which of the following applications are parts of FME Desktop?

1) FME Workbench
2) FME Server
3) FME Quick Translator
4) FME Universal Viewer

Which of the following tools is not found in FME Workbench?

1) A data viewing tool
2) A source data selection tool
3) A destination data selection tool
4) Data manipulation tools

Which of the following windows are on the Workbench interface?

1) Navigator
2) Transformer Gallery
3) Log Window
4) Display Control Window
Setting up a Translation

*Workbench’s intuitive interface makes it easy to set up and run a simple format-to-format (‘quick’) translation.*

**Dialog or Wizard**

Although a new translation can be created from scratch within a blank workspace, it’s more useful to get a head start by generating a translation with either the Generate Workspace dialog or wizard.

Both let users choose the source format and dataset, the destination format and dataset, and any settings.

Either of these methods can be accessed through the Create Workspace dialog (available on the start window or through File > New on the menubar) or the Generate Workspace dialog available on the start window.

**Terminology:** In most cases FME uses the terms ‘Reader’ and ‘Writer’ instead of ‘Source’ and ‘Destination’. Session 3 explains the why. For now, just be aware that a Reader reads datasets and a Writer writes datasets, and these terms are analogous to source/destination and input/output.

**Translation Workspace Wizard**

The Translation Workspace Wizard presents a series of choices through which the translation will be defined.

The initial screen of the workspace wizard prompts the user to select the format of the source datasets to be translated.

A red color indicates a compulsory field.

All format selection dialogs in FME are both a pull-down menu and a text entry field. The drop-down list shows the last ten formats used, so favourite formats are instantly available. The text entry field allows you to type a format name directly. It has an ‘intelli-complete’ function that selects close matches as you type.

Format selection can also be made by browsing through the Formats Gallery.
Generate Workspace Dialog

The Generate Workspace dialog condenses all the choices of the Translation Workspace wizard into a single dialog box. This is the preferred workspace creation tool for experienced users.

The Generate Workspace dialog has fields for the Reader and Writer Formats and Datasets. These prompts have the same drop-down menu and 'Intelli-complete' properties as the Workspace wizard.

The red fields indicate mandatory fields. Users must enter data in these fields to continue. Notice that the OK button is de-activated until the mandatory fields are complete.

There are also buttons for checking and/or altering settings for each dataset, and a button for previewing the data in the FME Universal Viewer.

The Create Workspace button on the Workbench toolbar is a shortcut to the Generate Workspace dialog.

It’s always worth checking the settings at this point. Although most settings will be exposed in the Workbench Navigator window, and can be set there, some settings affect how the translation workspace will be created and so need adjusting before you accept this dialog.

Feature Types Dialog

Whichever method of workspace creation is used, whenever a Reader (source) Dataset contains a number of different layers the user is prompted to select which layers they want to translate.

This is achieved through the Select Feature Types dialog. In FME ‘Feature Type’ is another term for ‘layer’. Only selected layers show in the workspace.

In the Generate Workspace dialog, why might it be useful to set the data format before browsing for the source data?

Try browsing for a dataset before setting the format type and see if you can detect the difference.

Here, for example, is a Select Feature Types dialog where the user has chosen to include all available layers within the workspace.
**The New Workspace**
A new workspace reads from left to right, from a source (Reader), through a dataflow to a destination (Writer). One could also think of these as the Extract-Transform-Load stages of a spatial ETL process.

A new workspace resembles this example.

FME places annotation to emphasize the E-T-L structure (Source > Flow > Destination).

Arrows denote the direction of data flow, from source to destination.

**Running the Translation**
The green arrow (or ‘play’ button) on the Workbench toolbar starts a translation.

There are also options under **File** on the menu bar to either ‘Run’ or ‘Prompt and Run’ a translation.

The File menu with run options include shortcut keys that can be used – the F5 key to simply run a translation and Ctrl+R to prompt and run a translation.

**Saving the Translation**
Workspaces can be saved to a file so that they can be reused at a later date. Simply use **File > Save** (shortcut = Ctrl+S) or **File > Save As…** to save the translation.

The default file extension is .fmw. Double-clicking a *.fmw file in Explorer starts FME Workbench and opens up the workspace.”

Firefighter Mapp says…
‘The file menu shows a list of previously used workspaces. This list is expandable to show up to a towering 15 entries.’

The ‘Run’ option carries out a translation using the same parameters and settings used previously. The ‘Prompt and Run’ option prompts for new values for parameters and settings.

Regardless of this, however, the ‘Run’ option must still prompt for parameters that have not yet been filled in and don’t have default values.
Translation Results

After running a translation statistics relating to the output results are found in the Workbench log window.

The translation log reveals whether the translation succeeded or failed, how many features were read from the source and written to the destination, and how long it took to perform the translation.

In this example the log file reveals that 2319 features were read from a MicroStation dgn file.

These features were written to a GML output file.

The overall process was a success (with 1 warning).

The elapsed time for the translation was 4.6 seconds.

When a translation is run immediately in Workbench or Quick Translator, without further adjustment, it’s known as a ‘Quick Translation.’

Because FME is a ‘semantic’ translator, with an enhanced data model, the output from a quick translation is as close to the source data in structure and meaning as possible.

<table>
<thead>
<tr>
<th>Example 1: Quick Translation</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Scenario</strong></td>
</tr>
<tr>
<td><strong>Data</strong></td>
</tr>
<tr>
<td><strong>Overall Goal</strong></td>
</tr>
<tr>
<td><strong>Demonstrates</strong></td>
</tr>
<tr>
<td><strong>Finished Workspace</strong></td>
</tr>
</tbody>
</table>

Let’s see how intuitive FME’s interface is by doing an example translation with minimal instruction.

Start FME Workbench and use it to carry out this conversion:

- **Reader Format**: Esri ArclInfo Export (E00)
- **Reader Dataset**: C:\FMEData\Data\CityGrid\city_grid.e00
- **Writer Format**: GML (Geography Markup Language)
- **Writer Dataset**: C:\FMEData\Output\TrainingModule1\Grid.gml

For now, ignore the Workflow Options and leave the default of ‘Static Schema’. Accept all feature types when prompted to select them.

Run the translation. Locate the destination data in Windows Explorer to prove that it’s been written.
Introduction to Data Inspection

Inspecting spatial data prior to, during, or after the translation is a helpful way to verify that the process is operating as expected.

What is Data Inspection?
One piece of FME marketing material once stated:

‘To ensure that you’re dealing with the right information you need a clear view of your data at every stage of the transformation process.’

Data Inspection meets this need. It is the act of viewing data for verification and debugging purposes, before, during, or after a translation.

What Can Be Inspected?
A number of different facets to spatial data may be inspected, including the following:

- **Geometry**: Is the geometry in the correct spatial location? Are the geometry types correct?
- **Symbology**: Is the color, size, and style of each feature correct?
- **Attributes**: Are all the required attributes present? Are all integrity rules being followed?
- **Data Format**: Is the data in the expected format?
- **Data Schema**: Is the data subdivided into the correct layers, categories or classes?
- **Data Quantity**: Does the data contain the correct number of features?
- **Process Output**: Has the translation process restructured the data as expected?

Chef Bimm says…

‘I have a great recipe for loading CAD files into a Building Information Model. Previewing the ingredients… I mean data… lets me detect problems before they affect the translation.

Features in the wrong source layer could need the whole process to be repeated. Data Inspection saves me that hassle.’

See Appendix A for a list of which geometries the FME data model supports.
Introduction to FME Universal Viewer

FME Universal Viewer is a Data Inspection utility for spatial data.

As you may have noticed, FME Workbench does not include any data viewing functionality. This inspection role is carried out by a complementary application, FME Universal Viewer.

What is FME Universal Viewer?
FME Universal Viewer (commonly called the ‘Viewer’) is a utility that allows viewing of data in any of the FME supported formats. It is used primarily to preview data before translation or to verify it after translation.

The Viewer can also be used to check data at any point during a translation; as you use FME you’ll find this is useful for step-by-step examination of complex translations.

FME Universal Viewer is closely tied to FME Workbench so that Workbench can send data directly to the Viewer. FME Universal Viewer also has basic tools for editing the display symbology.

What FME Universal Viewer Is Not!
FME Universal Viewer isn’t designed to be a form of GIS or mapping application. It has no all-around analysis functionality, and the tools for symbology modification and printing are rudimentary and intended for data validation rather than producing map output.

Although FME can handle true three-dimensional features, the Viewer shows data only in two dimensions. Full 3D support is handled by the FME Data Inspector application, now in beta and due for final release with FME2013.

Starting FME Universal Viewer
To start FME Universal Viewer, from the Windows start menu click **FME Desktop**, then on the submenu click **FME Universal Viewer**.
Major Components of the FME Universal Viewer

When the FME Universal Viewer is started, and a dataset is opened, it looks something like this:

**Menu bar and Toolbar**
The menu bar and toolbar contain a number of tools. Some are for navigating around the View window, some control administrative tasks such as opening or saving a dataset, and others are for special functionality such as selective filtering of data or the creation of dynamic attributes.

**View Window**
The View window is the spatial display area of the FME Universal Viewer. Multiple views of different datasets may be opened at any one time.

**Display Control Window**
The Display Control window shows a list of the open datasets and their feature types. Tools here let users turn these on or off in the display, alter their symbology, and adjust the display order.

**Information Window**
When users query a feature in the View window, information about that feature is shown in the Information window. This information includes the feature’s feature type, attributes (both user and format attributes), coordinate system and details about its geometry.

**Log Window**
The Log window reports information relating to the reading and look of a dataset that can be used to confirm whether data has been read correctly. Some functions on the toolbar also generate messages in the Log window.

**Status Bar**
The status bar is a general report of the status of the Viewer. It shows which feature is being read when a dataset is opened, indicates when the Viewer is drawing a dataset on screen, and prompts users when the Viewer is ready and waiting for user input.
Using FME Universal Viewer

With FME Universal Viewer it’s easy to open and view any number of datasets and to query features within them.

Viewing Data
FME Universal Viewer provides two methods for viewing data: opening or adding.

Opening a Dataset
Datasets can be opened in the FME Universal Viewer in a number of ways.

- Selecting File > Open Dataset from the menu bar
- Selecting the toolbar button Open Dataset.
- Dragging and Dropping a file onto any window (except the View window)
- From within Workbench

Opening data from within FME Workbench is achieved by simply right-clicking on a canvas feature type (either source or destination) and choosing the option ‘Inspect’.

All of these methods cause a dialog to open in the FME Universal Viewer in which to define the dataset to view. In the case of the Drag-and-Drop and Workbench Inspect methods, the dialog is automatically filled in by FME.

Adding a Dataset
Opening a dataset causes a new View tab to be created and the data displayed. To open a dataset within an existing view tab requires use of tools to add a dataset.

- Selecting File > Add Dataset from the menu bar
- Selecting the toolbar button Add Dataset
- Dragging and Dropping a file onto the view window
Inspecting Data
Once data has been opened in the FME Universal Viewer, there are a number of tools available for altering the view or querying features.

Windowing tools are:

- Pan
- Zoom In
- Zoom Out
- Zoom to a selected feature
- Zoom to a marked location
- Zoom to the full extent of the data
- Revert to the previous zoom extent
- Advance to the next zoom extent

Querying tools are:

- Query an individual feature
- Measure a distance within a View Window
- Query all non-geometry features

By default the Query tool is active when you start the FME Universal Viewer. Clicking the toolbar Query button at this point only turns the tool off.

The results of a feature query are shown in the Information window.

The upper part reports on general information about the feature; which type (layer) it belongs to and which coordinate system it is in.

The middle part reports the attributes associated with the feature. This includes user attributes and format attributes (for example fme_type).

The lower part reports the geometry of the feature. It includes the bounding box of the feature, the geometry type, the feature dimension (2D or 3D), and a list of the coordinates that go to make up the feature.
Now let’s see how intuitive the FME Universal Viewer interface is by inspecting the input and output datasets from any quick translation you have already carried out.

For example, you should be able to find the output from example 1 at:

**Format**: GML (Geography Markup Language)

**Dataset**: `C:\FMEData\Output\TrainingModule1\Grid.gml`

That dataset should look something like this:

FME 2012 makes it easier to locate either input or output data with a new tool in Workbench.

Simply right-click on any Reader or Writer feature type and choose the option “Open Containing Folder”.

---

**Example 2: Data Inspection**

<table>
<thead>
<tr>
<th>Scenario</th>
<th>FME user; City of Interopolis, Planning Department</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data</td>
<td>City Grid (ArcInfo E00 and Geography Markup Language)</td>
</tr>
<tr>
<td>Overall Goal</td>
<td>Inspect the city grid data from Example 1</td>
</tr>
<tr>
<td>Demonstrates</td>
<td>Data Inspection</td>
</tr>
</tbody>
</table>
More FME Universal Viewer Functionality

The FME Universal Viewer has a number of controls to assist in showing the data in an orderly manner.

Display Control
Display control is carried out in the Display Control window rather than through options on the toolbar or menu bar.

Datasets and feature types are shown in the same order in the view window as they appear in the Display Control window.

Each Dataset and feature type can be dragged above any other to promote its display order in the View window.

Layers can only be ordered within their container Dataset.

For example, BikeRoutesH > Area cannot be promoted above BikeRoutesL > Area unless the entire BikeRoutesH Dataset is also promoted above BikeRoutesL.

Display Status
Each level of the Display Control window has a checkbox to turn data on and off at that level. Turning off a higher level in the hierarchy turns off everything below it.

For example, clearing the checkbox for View 1 turns off data for the entire view. Clearing a dataset checkbox turns off data in the view for that particular dataset only.

Symbology
Each feature type can be assigned a different color or style that applies to all geometries. At a lower level each separate geometry type can be assigned a different color or style.

Mr. R.G.B. Color says…

‘A color defined with a disk symbol signifies that colors are defined by the source dataset, as opposed to being randomly selected by the FME Universal Viewer, which it does for non-color formats.’

Features in the wrong source layer could need the whole translation to be repeated. Data Inspection saves me that hassle.’
Miscellaneous Viewer Functionality
FME Universal Viewer has a number of miscellaneous functions that help users navigate through data, investigating data, and even translating data to a different format!

Shift and Ctrl Key Functions
Press the Shift key on the keyboard and it will activate the zoom-in tool in the Viewer. Press the Ctrl key and it will activate the zoom-out tool. Release the key to revert to the previous tool.

This functionality allows users to quickly move between query and navigation modes at the press of a key, so there’s no need to click between query and navigation tools on the menubar or toolbar.

Save Tools
The FME Universal Viewer has two 'Save' tools on the menubar.

File > Save Data As is used to convert the currently open data to a different format. Only data shown within the current View window will be output, so a crude envelope can be set by using the windowing tools to show only the area of data required.

File > Save Viewspace is used to save the current Viewer setup, including details of the open datasets and the symbology/layout used to display them.

Saving a viewspace allows the use to view the same data in the same way, at a later date, without having to open each dataset individually and without having to re-create the same symbology.

Display All Coordinates
The default coordinate list in the Information window is restricted to a maximum of 50 coordinates. This optional restriction can be turned off by selecting View > Options > Display All Coordinates.

Decimal Precision Display
By default, coordinates are displayed in a truncated format. To show coordinates full decimal precision select View > Options > Display Full Decimal Precision from the menubar.

Full precision is vital for checking geometric processes; for example, examining a polygon to check it closes correctly.
The Mayor of Interopolis is planning to purchase a house and wants you to examine the City's data to locate a good part of the city to live, that fulfills the following requirements.

1) In a middle school catchment area
2) In an area that includes at least one city park
3) In a quiet area (so one that doesn’t include the airport or any railroad)

1) Start the FME Universal Viewer.
Start the FME Universal Viewer by selecting its shortcut from the Windows Start menu.

2) Open a Dataset – Schools
The first task is to open the school regions dataset.

Select File > Open Dataset from the menu bar in FME Universal Viewer. The standard FME dataset selection dialog will open.

Set the following parameters:

Format: GML (Geography Markup Language)
Dataset: C:\FMEData\Data\Schools\schoolRegions.gml

The dataset opened contains information about all types of schools in the city, but you are only interested in middle schools.

In the Display Control window, uncheck the boxes for high schools, primary schools and school districts.

3) Add a Dataset – Parks
Additional datasets may now be added to the view.

Select File > Add Dataset from the menu bar. Again the dataset selection dialog will open. This time choose the following parameters:

Format: MapInfo TAB (MFAL)
Dataset: C:\FMEData\Data\Parks\city_parks.tab

Notice how the data is added to the existing View, rather than opening a new View.
4) Add Datasets – Railroad and Airport
Now add the railroad and airport datasets. Do this by dragging-and-dropping the files from Windows Explorer into the current View window.

The dataset selection dialog will now open again; this time the settings will already be filled in. FME has determined them from the dataset you have chosen.

<table>
<thead>
<tr>
<th>Format</th>
<th>CITS Data Transfer Format (QLF)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dataset</td>
<td>C:\FMEData\Data\Airport\airport.qlf</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Format</th>
<th>Autodesk MapGuide SDL</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dataset</td>
<td>C:\FMEData\Data\Railroads\railroad.sdl</td>
</tr>
</tbody>
</table>

5) Adjust the View
One potential problem is that datasets added to the View may be hidden beneath the original school dataset. To be visible they need to be promoted above the schools.

If necessary, promote the railroad dataset (for example) click the ‘Dataset: SDL (railroad)’ item, keeping the mouse button depressed. Drag the dataset to the top of the display, above the school regions dataset. Release the mouse button. Repeat for the parks and airport datasets as required.

6) Adjust Symbology
In the Display Control window click the color icon for a dataset to change the color of features for that dataset. Use the following colors:

- School Areas: Gray
- Parks: Green
- Airport + Railroad: Red

7) Querying
Use the windowing tools on the toolbar to zoom in closer to examine each school area. Visually determine which school areas contain parks, but not railroads or the airport.

By now you should be able to pick a single school area that is the most suitable for the mayor’s requirements. Use the Query tool to discover the names of that area.

8) Save Viewspace
Having arranged the data into a suitable display, now save the setup as an FME viewspace; then you can open it again later as predefined data without having to go through all the above stages.

9) Export Data
The mayor’s office has phoned up and says he would like to see the map data as a visual display. He doesn’t have access to FME or the source data, but he does have Google Earth.

Use **File > Save Data As** to save the data as KML so that the mayor can view it in Google Earth. Open the data yourself to verify that it looks correct (albeit not very well stylized).
With cells rather than features, the techniques for inspecting raster datasets are slightly different to those for vector.

Opening a Raster Data in the Viewer
The same open and add tools work for opening both raster and vector datasets.

For example, here is the Interopolis CDED format elevation model (DEM) Dataset opened in the FME Universal Viewer. The value of the selected cell is reported in the lower-right corner of the information window.

Mixing Vector and Raster Datasets
The FME Universal Viewer is capable of showing both raster and vector datasets simultaneously.

Here is a MrSID raster dataset overlaid with the Interopolis parks (vector) dataset.
Querying Raster Features
There are two ways to use the query tool on a raster dataset: one to query a cell and one to query the raster dataset itself.

Querying a Cell
A single click onto a raster dataset queries the cell under that click. This gives the output shown.

Querying the Dataset
A click and drag motion that selects an area of the raster dataset queries the dataset itself. This gives the output shown.
Here is one example of a bitmap image (an FME splash screen) opened in the FME Universal Viewer.

This is a good example of a color image—each cell value is a triplet that defines the RGB cell color (the green in Safe’s logo is 147, 193, 78).
Example 4: Handling Raster Data

<table>
<thead>
<tr>
<th>Scenario</th>
<th>FME user; City of Interopolis, Planning Department</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data</td>
<td>Raster image (LizardTech MrSID)</td>
</tr>
<tr>
<td>Overall Goal</td>
<td>Convert data from MrSID format to JPEG format.</td>
</tr>
<tr>
<td>Demonstrates</td>
<td>Raster data translation and inspection</td>
</tr>
<tr>
<td>Finished Workspace</td>
<td>C:\FMEData\Workspaces\DesktopManual\Session1Example4Complete.fmw</td>
</tr>
</tbody>
</table>

1) Start FME Workbench
Start FME Workbench.

2) Set up Translation
Set up a translation using the following parameters:

- **Reader Format**: LizardTech MrSID
- **Reader Dataset**: C:\FMEData\Data\Raster\130105.sid
- **Writer Format**: JPEG (Joint Photographic Experts Group)
- **Writer Dataset**: C:\FMEData\Output\TrainingModule1\n
For now, ignore the Workflow Options and leave the default of ‘Static Schema’. On this occasion, the writer dataset demands a folder, and not a specific filename.

3) Run Translation
Run the translation.

4) Inspect Output
Inspect the output from this translation using the FME Universal Viewer.

Judge GIS says...

"Members of the Jury: Safe Software suggests that raster data is as easy to handle in FME as vector data. Please pass judgment on this claim by doing this example translation!"
Translation Previews

A key ability of FME is communication of data between Workbench and the FME Universal Viewer.

Redirect to Inspection Application
In some cases it’s desirable to inspect output data, but undesirable to actually have to write the data to do so. In other words, you want to preview what the output of a translation will be.

For example, it would be useful to preview the results of a Workbench translation that updates a spatial database. That way mistakes can be detected before writing to the database.

The Workbench tool to do this is the ‘Redirect to Inspection Application’ setting.

When this setting is applied, the output from a translation is redirected away from the specified output and sent directly to FME Universal Viewer instead.

The simplest way to turn on this ability is to select Writers > Redirect to Inspection Application on the Workbench menu bar.

This setting is a toggle, which means that each subsequent selection alternately turns the setting on and off.

Here a user is about to activate the Redirect to Inspection Application setting. Absence of a checkmark shows it is not already set.

An embarrassing problem occurs when a user forgets to deactivate the setting and does not understand why no output datasets are being written. To help combat this issue, the FME Log window includes a distinctive warning message when data is being redirected.

Notice how the redirection message in the FME Log window reports that zero features have been written to the output datasets.

Don’t get confused by the Inspection option on the menubar. It is entirely unrelated to this form of Inspection and the Viewer.
Introduction to FME Quick Translator

The FME Quick Translator is a new incarnation of the FME Universal Translator, the original FME tool for Data Translation and Transformation.

What is the FME Quick Translator?
In a previous example FME Workbench was used to carry out what is known as a “quick translation”.

The FME Quick Translator is designed to carry out quick translations without having to go through the workspace creation process. This is quicker (hence the name) but cannot be saved, so is not reusable.

It is also designed to run existing workspaces that do not need further editing.

Starting the FME Quick Translator
Find FME Quick Translator in the FME Desktop > Utilities sub-menu in the Windows start menu. Click on the sub-menu entry to start the FME Quick Translator.

Setting up a Translation
To set up a translation, choose the option File > Translate on the menu bar.

Notice how the “previous files” list contains previously run translations (.fme and .fmw files) but also previously translated datasets.

Translate is also available as a button on the toolbar.
**Translation Dialog**
Selecting **File > Translate** on the Quick Translator menu bar opens the translation parameters dialog.

When the translation parameters have been filled in and the OK button clicked, the translation is immediately carried out.

The Quick Translator translation parameters dialog looks like this.

Here the user is converting a MapInfo TAB dataset into GML (Geography Markup Language).

**Running an Existing Translation**
The FME Quick Translator may also be used to execute an existing translation, whether it's a workspace or a mapping file.

This is of use where a user has been supplied with a mapping file or workspace that does not require further editing (and may even have been password protected to prevent changes from being made).
Your objective is to convert the Engineering Department’s dataset of railroad data from the Autodesk MapGuide SDL format to the Planning Department’s preferred format, which is MapInfo MIF/MID.

1) **Start FME Quick Translator**
Start the FME Quick Translator and select File > Translate from the menubar.

2) **Set up Translation**
In the Translation Parameters dialog, set the Reader and Writer parameters as follows:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reader Format</td>
<td>Autodesk MapGuide SDL</td>
</tr>
<tr>
<td>Reader Dataset</td>
<td>C:\FMEData\Data\Railroads\railroad.sdl</td>
</tr>
<tr>
<td>Writer Format</td>
<td>MapInfo MIF/MID</td>
</tr>
<tr>
<td>Writer Dataset</td>
<td>C:\FMEData\Output\TrainingModule1</td>
</tr>
</tbody>
</table>

*Note:* When writing MIF/MID format you select a folder and not a specific file name.

3) **Run Translation**
Click OK to run the translation.

4) **Inspect Data**
Inspect both the source and the newly-created destination datasets, to prove that they are the same and that the translation was successful.

5) **Advanced Task**
Repeat the same translation in FME Workbench, and then from the command line!

The command syntax is shown in the FME Workbench Log window but – provided you browse to the folder in which the workspace resides – you can also attempt the following:

`fme <workspacename>.fmw`
Module Review

*This module was designed to introduce you to FME and to investigate the basics of FME data translations.*

What You Should Have Learned from this Module

The following are key points to be learned from this module:

**Theory**

- FME is a tool to **translate and transform** spatial data.
- **Quick Translation** is the technique of carrying out a translation with minimum user intervention. The **semantic** nature of FME is the means by which this is permitted.
- **FME Workbench** is an application to graphically define a translation and the flow of data within it. This definition is known as a **workspace** and can be saved to a file for later use.
- The **Workspace dialog** and the **Workspace wizard** are the two methods by which a Quick Translation can be set up in FME Workbench.
- **Data Inspection** is a technique for checking and verifying data before, during, and after a translation.
- The **FME Universal Viewer** is a tool for inspecting data. Multiple datasets – including data from different formats – can be opened within the same View window.
- **FME Quick Translator** is an application to carry out Quick Translations, or to run predefined workspaces.
- FME has a wide range of **supported geometries**

**FME Skills**

- The ability to start FME Workbench, set up a Quick Translation, and run it.
- The ability to start FME Universal Viewer, open a dataset in a new View, and add a dataset to an existing View; to navigate a dataset and to query features within it.
- The ability to control minor FME Universal Viewer functionality for debugging data and translations.
- The ability to inspect both raster and vector dataset types.
- The ability to run the Quick Translation within the FME Quick Translator.
- The ability to inspect data by redirecting it from FME Workbench to FME Universal Viewer.
Q&A Answers

Miss Vector says…

‘Here are the test answers. Anything less that 4 out of 4 and you’ll find yourself reviewing the section again during lunch!’

Which of the following words describe FME Desktop?

1) Distributed
2) Semantic ✓
3) Transformational ✓
4) Centralized ✓

Which of the following applications are parts of FME Desktop?

1) FME Workbench ✓
2) FME Server
3) FME Universal Translator ✓
4) FME Universal Viewer ✓

Which of the following tools is not found in FME Workbench?

1) A data viewing tool ✓
2) A source data selection tool
3) A destination data selection tool
4) Data manipulation tools

Which of the following are windows in the Workbench interface?

1) Navigator ✓
2) Transformer Gallery ✓
3) Log Window ✓
4) Display Control Window

Why might it be useful to set the data format before browsing for the source data?

Try browsing for a dataset before setting the format type and see if you can detect the difference.

Answer -
When you set the format and then browse for a dataset FME will show only datasets of the chosen format, making the selection task easier.

When you browse for a dataset before setting the format, FME will show all files.
Appendix A: Supported Geometries

To effectively support all the formats that it does, FME has a comprehensive geometry model that includes everything from the simplest geometry to the most complex.

It’s important to be familiar with geometry types you will encounter within FME, particularly with how they are reported within the FME Universal Viewer. This section is a comprehensive list of these geometry types and includes items you may not need to be personally familiar with.

There are some geometries that are expected to be supported by most, if not all, data formats. Other geometries are more format-specific: they may not appear in every format and not every user would need to know about them.

See C:\FMEData\Data\DemoData\GeometryExamples.ffs for examples of most of the basic geometries.

Non-Geometry
A non-geometry feature is a set of attributes without geometry.

<table>
<thead>
<tr>
<th>ID</th>
<th>Street_Name</th>
<th>City</th>
</tr>
</thead>
<tbody>
<tr>
<td>1234</td>
<td>Station Rd</td>
<td>Cowfold</td>
</tr>
</tbody>
</table>

The commonest non-geometry feature is a simple database record.

Points
Point geometries are features represented by a single coordinate.

A simple point feature has just an x/y coordinate; but there are other point geometry subtypes.

Ellipses are basically circle or oval features; like an arc but closing on themselves, so don’t require a start angle or sweep angle.

Each Point Cloud feature is made up of a large number of unconnected point features.
**Text**

Text features represent the position of an annotation.

*Text features’ definition optionally includes size, rotation, and justification. Although text features are traditionally thought of as a single x/y coordinate, they can have a line or other geometry.*

---

**Lines**

A line is a series of points strung together to form a chain.

<table>
<thead>
<tr>
<th>The simplest form of line geometry is a <em>two-point line</em>; that is, it has a start coordinate and an end coordinate but no intermediate points.</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="Image" alt="Two-point line" /></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>A <em>polyline</em> feature is a multi-point line; that is, it has a start coordinate and an end coordinate plus a number of intermediate points.</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="Image" alt="Polyline" /></td>
</tr>
</tbody>
</table>

---

**Arcs**

Arcs are a bit of a special case. They can be defined in multiple ways with FME, and don’t really fall under either point or line features.

<table>
<thead>
<tr>
<th><em>Arc</em> features are often defined by an x/y coordinate at their centre point, plus a mathematical definition of arc radius and sweep angles.</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="Image" alt="Arc definition 1" /></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>An alternate arc definition is the centre point, plus the two end point X/Y coordinates</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="Image" alt="Arc definition 2" /></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>A further arc definition is the two end points, plus the mid-point of the arc ‘line’.</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="Image" alt="Arc definition 3" /></td>
</tr>
</tbody>
</table>

---

**Polygons**

A polygon feature is a series of points strung together, whose first and last points coincide to form a closed shape.

<table>
<thead>
<tr>
<th>A simple polygon forms a single closed shape.</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="Image" alt="Simple polygon" /></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>A donut is made up of an outer boundary to define a perimeter and an inner boundary to represent a hole within it.</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="Image" alt="Donut" /></td>
</tr>
</tbody>
</table>

---

**Note:** Usually donut boundaries are polygons, but FME can support an ellipse used as either the inner or outer boundary (or both)!
**Aggregates**
An aggregate is a defined set of any of the above features. It is also sometimes known as a ‘collection’ or ‘group’.

| A homogeneous aggregate is made up of features of the same geometry type. | ![Homogeneous Aggregate](image) |
| A non-homogeneous aggregate is made up of features with differing geometry types. | ![Non-Homogeneous Aggregate](image) |

**Raster**
A raster geometry feature is a set of pixels or cells in a grid.

| A Raster feature is a set of cells, not an individual cell. Cells do not generally have attributes, but may possess a single value or color. | ![Raster Feature](image) |

**Paths**
A path (also called chain) is a linear object made up of a number of features connected together.

| A path can be made up of features of the same geometry type or, more commonly, of different geometry types; for example, line-arc-line. | ![Path](image) |

**Surfaces**
Surfaces are three dimensional planar features. There are many types of surfaces supported in FME, including faces (see illustration below), meshes, triangle strips, and triangle fans.

| A face is one example of a surface feature. It’s a planar polygon or donut stored as a true 3D feature. | ![Face](image) |
| A surface may contain holes, in much the same way as a donut polygon. | ![Surface with Holes](image) |
**Solids**

Solids are three-dimensional entities. There are many types of solids supported in FME. These include boxes (see illustration below), extrusions, b-rep solids, and CSGs (see illustration). Although similar, these different types of solids are required for compatibility with the full range of FME-supported formats.

A **Box** is one example of a solid feature. Like a hole or donut, it can contain a void within it.

A **CSG (Constructive Solid Geometry)** is a complex object made up of a set of solids upon which a Boolean operation has been carried out. Boolean operations that can be carried out are **Union** (right), **Difference**, and **Intersection**.

**3D Multiples**

Multiples are the 3D equivalent of aggregates. They are always homogeneous, which means that they are made up of the same type.

**Multi-surfaces** are one example of this type of geometry. They are multiple surface features related as a collection. A **Composite Surface** is a multi-surface where all items are connected topologically.

**Named Geometries**

All features can be given a name to their geometry. This is achieved with the transformers: **GeometryNameSetter**, **GeometryNameExtractor**, and **GeometryNameRemover**.

Naming can be ‘recursive’; for example, this feature is an aggregate named ‘as-built’, whereas its components are named ‘roads’.

| Geometry Type: IPM3MultiCurve           |
| Name(utf-8): 'AsBuilt'                  |
| Number of Curves: 2                    |
| Curve Number: 0                        |
| Geometry Type: IPM3Line                |
| Name(utf-8): 'Road'                     |